Recebendo um erro ao tentar executar adicionar comando de migração no console do gerenciador de pacotes

votos
32

Preciso de outro par de olhos para olhar para isso. O código a seguir está sendo executado no visual studio e quando ele está ocioso barra lateral verde indica que a sintaxe está correta.

No entanto, quando eu executar uma migração add no console gerenciador de pacotes ele responde com o seguinte erro.

Objeto inválido passada, ':' ou '}' esperado (817).

Parece ter problema com minha implementação dependência, mas não consigo encontrar qualquer instância de um suporte ou uma vírgula faltando.

Se você pode encontrá-lo eu o prazer de fornecer a sua resposta com uma votação para cima. Obrigado!

{
  buildOptions: {
    emitEntryPoint: true,
    preserveCompilationContext: true
  },
  dependencies: {
    Microsoft.NETCore.App: {
      version: 1.0.1,
      type: platform
    },
    Microsoft.AspNetCore.Diagnostics: 1.0.0,
    Microsoft.Extensions.Configuration.FileExtensions: 1.0.0,
    Microsoft.AspNetCore.Server.IISIntegration: 1.0.0,
    Microsoft.AspNetCore.Server.Kestrel: 1.0.1,
    Microsoft.Extensions.Logging.Console: 1.0.0,
    Microsoft.Extensions.Configuration.Json: 1.0.0,
    Microsoft.AspNetCore.StaticFiles: 1.0.0,
    Microsoft.AspNetCore.Mvc: 1.0.0,
    Microsoft.EntityFrameworkCore.SqlServer: 1.1.0,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final,
    Microsoft.AspNetCore.Identity: 1.0.0 //New package required for added functionality
  },
  frameworks: {
    netcoreapp1.0: {
      imports: [
        dotnet5.6,
        portable-net45+win8
      ]
    }
  },
  publishOptions: {
    include: [
      wwwroot,
      web.config
    ]
  },
  runtimeOptions: {
    configProperties: {
      System.GC.Server: true
    }
  },
  scripts: {
    postpublish: [ dotnet publish-iis --publish-folder %publish:OutputPath% --framework %publish:FullTargetFramework% ]
  },
  tools: {
    Microsoft.AspNetCore.Server.IISIntegration.Tools: 1.0.0-preview2-final,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final
  }
}
Publicado 22/11/2016 em 17:49
usuário
Em outras línguas...                            


1 respostas

votos
6

O único problema que detectar no seu json é o comentário que você tem aqui

//New package required for added functionality

Os comentários não são válidos em uma estrutura JSON então provavelmente erro está relacionado a isso.

Respondeu 22/11/2016 em 17:54
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more